寒窗轩,寒川的个人网络博客,记录互联网事,学习网络编程、分享工作经验、人生感悟,包括但不限于程序代码、数据库、Office办公、随笔等内容。

ubuntu24.04无法安装向日葵,提示依赖libgconf-2-4怎么办?

在向日葵官方下载的deb包,目前是SunloginClient_15.2.0.63062_amd64.deb,执行安装代码,如下:

sudo dpkg -i SunloginClient_15.2.0.63062_amd64.deb

提示错误如下:

截图 2024-05-15 21-00-05.png

根据提示,发现依赖libgconf-2-4,而ubuntu24.04并没有这个版本。执行如下命令,发现系是安装了libwebkit2gtk-4.1-0的,如下:

sudo find / -name libwebkit*

截图 2024-05-15 21-02-47.png

那么,解开deb包,更改依赖关系后再打包就可以安装了。

操作如下:

sudo dpkg-deb -X SunloginClient_15.2.0.63062_amd64.deb sun
sudo dpkg-deb -e SunloginClient_15.2.0.63062_amd64.deb sun/DEBIAN
sudo vim sun/DEBIAN/control  #第8行改成如下

截图 2024-05-15 21-05-31.png

执行如下命令进行打包成deb后就可以安装了。

dpkg-deb -b sun #打包
sudo dpkg -i sun.deb

ok,祝你好运。

系统 2024-05-15 21:09:37 3 0 727 ubuntu向日葵linux
文章写得不错?我是土豪我要在线打赏!
在线打赏

昵称:

验证码:验证码

评论:

文章分类
系统
程序
数据
Office
随笔
热门文章
Excel文件内容很少,但文件很大,打开很慢、很卡怎么办?
请不要奇怪,为什么最近博客的文章是几年前的内容
Excel动态引用各表格指定单元格数据
开篇第一章
Excel文件内容很少,但文件很大,打开很慢怎么办?
如何利用python修改文件的创建时间,修改时间,访问时间
发现一个好网站——春燕文档
Ubuntu22.04中用thunar替换默认文件管理器,提示无法启动“TerminalEmulator“的首选应用程序
MySQL如何按每个分类查询10条数据,即MySQL如何每个分类查询10条数据
ubuntu24.04无法安装向日葵,提示依赖libgconf-2-4怎么办?
文章推荐
免责声明
关于博主
开篇第一章
随机推荐
今天将ubuntu12.04升级到13.04
想说点什么
php中定义变量
html 5学习-video标签插入视频
超酷绚的Excel点选变色,自动求合功能
是否我们都老了?
我今年二十七八岁
PHP+MySQL基于地理位置信息的附近交友的实现
留言
给验证码添加一个点击刷新的功能
友情连接
春燕网络
春燕文档
谢润的博客